Jun 172016
 

Manche meiner bei 1&1 gehosteten Sites zeigten plötzlich nur noch: internal server error.

Was war der Grund?

1&1 hat ein Update von Apache 2.2 auf 2.4 gemacht. Es wäre schön, wenn dies vorher angekündigt worden wäre, denn z. B. die Syntax in der .htaccess ist teilweise völlig anders.

Beispiel aus einer .htaccess für Apache 2.2:


Options All -Indexes
<files readme.html>
Order allow,deny
Deny from all
</files>

Das muss für Apache 2.4 wie folgt aussehen:


Options -Indexes
<files readme.html>
Require all denied
</files>

Hier alle Upgradehinweise: http://httpd.apache.org/docs/2.4/upgrading.html